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Overview

1. Overview

This document has been created in order to introduce straton Editor to new users allowing them to create
a new application from scratch, to test it and download it to a straton Runtime easily.

2. Requirement and setup

The straton Editor needs to be installed on a Windows PC. If the application needs to be downloaded to
a Runtime, it needs to be running. The PC and the Runtime need to be on the same network.

Download and install from

3. Demo Application

After finishing this tutorial, you could open Straton and play with the different demo application which
you can open after starting Straton. In Demo Projects

Fie View Tools Window Help
W BB [N |44 | &
Workspace Start Page.

Welcome to straton Editor

Tutorial r . Tips and tricks.
Getting started with straton pdf |Lock a program

Protect a project
Protect a program
Programming language
Convert a program

Big structures
‘Snapshet a program
Find tutorials

Execution order —

Drageirop variables How to lock a program with a password
Inthis short video, you will leam how 1o lock a program
MORE.. with a password in stralon

0 orkspac W Cross refersncas  Call es  Execubion  Call stack  Breakpoints  Digital samplingfrace  Prompt_HMI_Cods Chacker
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https://straton-plc.com/telechargements/

Demo Application

You will find a:
» Coffee Machine
SFC Programming
Simple Graphic Interface
» Energy_61850
IEC61850 Protocol for energy with GOOSE message
»  Samples

Basic examples of programs in FBD, SFC, ST, Ladder

File Edit View Insert Project Toels Window Help

BBE |G 0 KFXS|eleuis N AGESSa656 @

Workspace CoffeeMachineDisplay.gra
4 B CoffeeMachine P L
d --Gl'aphic b . s s s e e e e
f+ coffeeMachineDispl.. § SI0 0Ll
-—
4§ Programs —
[& control ("controls the... | .
Filling (*emulates the... | 7 -
&z Fieldbus Configurations |5t
{up Variables T
4 E Types :;
E BitFields ll
s
E Enumerated Data Ty. pi=]
E Structures o
E Unions o0 ]
B (4 Projects) = 1l
B
- -
8
e
@
My .
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Create and configure an application

4. Create and configure an application

4.1. Creating a new application
When opening straton Editor, the Start Page is displayed.

It contains the most useful shortcuts to create or open project.

BEX|

Workspac ‘Start Page

Welcome to straton Editor straton

Recent

Dem: ojects
Calf i

To create a new project, click on File > Add New Project... or click directly on the “Create new project”
shortcut.

File View Tools Window Help

fr1 Mew Project List... [ o

Open Project List 2

it  Add Mew Project...
Add Existing Project  »

Print Setup...
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Create and configure an application

Choose a name for the project and click on Next.

[E) Project wizard >
Il

@ Praject

D From ternplate
ML Impart

Q Library

'ﬁs Autornation script
& From GIT

Create a new project

MNew project
Drestination folder: |I::\T5 - Browse...
M arme: |_Tutorial |
Comment: | |

Note: No space neither special characters must be used, and maximum 15 characters are allowed.

Choose the programming language of the Main program (SFC, FBD, LD, ST, IL) then click on Next in order
to select I/Os and fieldbuses. If none is required, then click on Finish.

Settings x

Programs

Language: FBD: Function Block Diagram ~

Compiling options

(@) Debug

(O Release

Communication options

Settings: 192.168.33.120:502
Protocol: T5 Runtime .
Other

[“] Edit initial values with the Recipe editor

Use the General Purpose Library

Previous Finish Cancel
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Create and configure an application

The project is now visible in the straton workspace.

+ Tools Window el
XS|o|«+4e|faBAgEh dn ™

——————

4.2. Editing a program

Double click on Programs > Main to open the Main program (here in FBD language).

Fie Edit View Inset Project Tools Window _Hel
BMEL G ATrXS|o|l«+ e QEh g ™

B i values
1} @inaing Connguration

b Trpes
W (A Projects)
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Create and configure an application

Note: Double click on the name “Main” and not on the icon.

A small padlock appears on the program'’s icon. It means it is now in Edit mode so you cannot remove it
from the workspace. () Main)

Type | Dim. | Attrib. | Syb. [Initval... | Use... |TAG | Descrip

) Main
) Global variables
RETAIN variables

< >
[ JC0) ~
B (Project)

B Advanced

B writhmetic

B Arays

B AS-interface

@ BACnet

@ Booleans

@ CANbus

@ CANopen

B clock

@@ Comparisons

Ol =mT s E| B+ 1| 5000

B

B

@ Conversions

@ Counters

W ones

@ Embedded HMI
@ EthemetIP (ODVA)
@ EthemetPowerlink
W Files

@@ GeneralPurpose

[BEIEDY soylist Define ENUM  Graphics

It is now possible to choose Function Blocks for the program.

For example: in Blocks > (All), select & (*Boolean AND*)

o |
[ M

kg {1 Clobal variables

=) RETAIM vaniables

[.]

&

.
=
=

w
»

v

4k

|
O

A

o)

£
%
“

b 9

W <("Less than")
5 Less or equal’)

3 Is not equal’)

"Greater of equal’)
 item (3 dim)*)
)
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Create and configure an application

When drag and drop the block in the program, it automatically contains the variables.

Trick : Click on CTRL button before dropping to remove variables.

| Type | Dim. | Attrib. | Syb. |[Init val... | Use.

[ Main
£} Global variables
RETAIN variables

[2 (Boolean AND')
N

ol =wT|vE B[ -1 |600o[D

IN:BOOL < e
>

IN:BOOL < Properties

A

ouT
Q:BOOL i &(*Boolean AND*)

* (*Multiply®)

sleElE

1(*Divide")
25 1("copy (1gain)")
i <(*Less than*)

i <=("Lessor equal’)
< (s not equal’)

2=

>=("Greater or equal*)

15 > [IJ,K] (*Put array item (3 dim)*)
;> [I,J1(Put array item (2 dim)")
3 »>[] (*Putarray item (1 dim)*)

#5 [1,0,K]>> (*Get array item (3 dim)*)
15 [1,J]>> (*Get array item (2 dim)*)
25 [0>> ("Getarray item (1 dim)*)

T} abs (*Absolute value®)

MY Spyiist Define ENUM  Graphics

Now, the Function block is in the program. As in the screen below, the (&) block needs three variables (2
Boolean inputs and 1Boolean output).

To add variables, double click on the « ??? » fields.

Enter a name for the variable. Here, « Input? ».

¥ [ Hame Type Dim. | Astrib. Syb. |Initval... |Use... De:
[ Main
T far Global vaniables
= B RETAIN variatles
=3
L
-
»
r
= "
1
¥
4
9
]
k-
W
§u
{*Greater than®)
= {"Greater of equar’)
> [LJK] (*Put array lem (3 dim)
D41 (*Putarray item (2 dim)")
me array fem (1 dim)’)
Get array tem (3 dim)
1> (*Getarray item (2 dim)")
>> ["Gel array item (1 dim)")
. ues)
E ERIITTTTY sowmst Oene ENUM Graphics
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Create and configure an application

As the variable does not exist in the project’s dictionnary, when clicking on "OK" a popup window appears.
In this window it is possible to choose the type of the variable, where to declare the variable and an
optional description. Note that in FBD, straton automatically recognizes the type of variable to declare

when it is linked to a block.

Click on Yes to finish.

W Inputt et
Thiz symbal does not exizt. Possible actions:
Rename wariable
(®) Declare new variable
M amne: [Fput
Type: | BOOL
Where: | Main w |
Dezcription: | |
it walue: | |
Idzer Group: | o |
TAG: | |
Advanced: [ ]Read-only (] IMOUT D E =
[ ]Extemal [ ]5yb.
Fewer Yes Ha Cancel Help

Create the second variable. Here, « Input2 » type BOOL, in the Main program. Then the output variable.

Here « Output », type BOOL, in the Main program.

Input1
Input2

Output

Variables are visible in the dictionary, on the top-right of the screen.
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Create and configure an application

H ]
a o
= o
Ty Global variables
5 RETAIN vanables
=Y
u:
»
r
3
ot ovont
J nputz
At
q
)
,
B
= )
5 <= ["Less or equal)
) <> ['ls not equar’)
15 oqual’)
> (‘Greater than)
= ["Greater or equal’)
>> [, (*Put aeray itom (3 dimI*}
£ 2> [LJ] (Put array ttem (2 dim)’)
£z »> [ (Putarray item 1 dimy)
£ [LAKI>> (Get array tem (3 gim)')
T 1] 2> (Get array item (2 dim)’)
1>> (“Getarray item (1 dim)')
. "ABSOMIE Valie") .

4.3. Building and compiling an application

Now it is time to test the project. First, click on this icon (Eﬁ) in order to build the project:

B ARG XK

4+ B _Tutorial

indow Help

A4 | EE P RQE S

b Exception programs 4 [ Main
. Programs o Input1 BOOL m}
Main o Input2 BOOL o
4 [ Waten (for debugging) o Output BOOL a
& Soft Scope { Global vanables
& inial values o ) RETAM variables
1 Binding Configuraion T
R Profies.
§g Global defines
{2 Variavies
b & Types

W (A1 Projects)

@
L3
»
=
x Inputt. Output
1 o
O
4
>
;

~

2

.

& <= ("Less or equal’)
< (s not equal’)
= ('ls equar’)
> (*Greater than"}

i >= (Greater o equal')

33 [J]>> ("Get array item (2 dim)*)
10> ("Get array item (1 dim)’)
(*Absolute value®)

| Varaies: Propct=130 | oftune 127001502 2o [ oxe | 00 100%
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Create and configure an application

You can see the result of the compilation in the “Build” tab.

Build
Loading application symbols.
Mo error detected

>k

Loading application symbols.

Main

pStartup

pShutbown

pONDVZero

pOnBadindex

Building application data.

<107 BOOUSINT, 5 INT, 26 DINTIREAL; 14 LINT/ALREAL; 0 TIME; 1 STRING; 0 WSTRING - CRC = 84becs01 >
<13 POUS - 2 programs, 8 sub-programs, 2 UDFBS >

Relocating code

< Code CRC=5ad 12892 - File CRC=593380d6 - Retain CRC=dedf14b3 - Size=2040 =
Mo error detected

Breakpoints _ Digital sampling trace  Prompt  HMI  Code Checker

Then, to test the project, start the simulation mode:

Fie ESt View Inset Project Tools Window Help

Bl(xl“X! = ﬁ‘]t:)’.i‘.iﬂ&Q!‘df‘

« B
b
4 o (=]
a o o
4 @ Waxh for dedugging) o Output BOOL (s}
® sonscope { Global vanables
B inial valuss ol B RETAIN variabies
10 Binding Contigursion *
2 Profles
§a Glosal defines =
Gy Variadles @
b Tpes -
W 2 Projects) >
=
: = L -
ez
O
4
9
i
-
Dvide’)
bad 1 Ccopy (1 gainy’)
=y <('Less man')
a <= ("Loss or oquar’)
I
§u > (‘Greater than’)
>= (‘Greater of equal’)
>> [14K) (Put array item (3 dam*)
>> [LJ] *Put array item (2 din*)
>> ] (Put array e (1 dim)’)
DL XK) >> (‘Get array item (3 dum)*)

Loading application symbols
Mo srror detected

Loaging application symos.

pStartup
pShutDown
PONDNZer0
£0nB3dncer

12l em RERORTY [ 00w |

Start mode X

(@ Cold start- Don't load RETAIN variables

Cold start- Load RETAIN variables

Hot restart

[Jeydeto cycle

The project is now in simulation mode.
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Create and configure an application

Jele A [ &M ANE S| BE AN =recm g =

[ Main] nEX
~ fr[Name [Value [ Type [ Dim_ Attib TSyb. [Initval [Use... [TAG
= 4 [ Main
° Input1 BOOL [m]
=] Input2 BOOL [m]
o Output BOOL a
i 4 Global variables
" RETAIN variables
&
s Input1 = FALSE 2 m Output = FALSE
=l Input2 = FALSE |
-
E3
|
o < >
-
@Q 4 WA a
o %3 &(*Boolean AND*)
. 23 * (*Multiply”)
[~ 3 +(rAddition®)
= 23 - (*subtraction”)
25 {("Divide”)
% 25 1 ("copy (1 gain))
Ed 2: <("Lessthan’)
[ 3 <= ("Less or equal)
B 23 <> (s notequal’)
5 ; =(Is equal’)
> (*Greater than")
23 >=("Greater or equal’)
23 >> [LJK] (*Putarrayitem (3 dim))
3 >» [LJ] (*Put array item (2 dim)*)
23 >>[I] (*Putarray item (1 dim)*)
3 [LJK1>> (‘Getarrayitem (3 dim))
3 [J]>> ("Get array item (2 dim))
v +oom e it (4 digi hd
ylist Define ENUM Graphics

To change the variables state, click on it and press the spacebar. Here, the variable goes from blue to red
when the variable goes from FALSE to TRUE.

Jolea]: [# &N A GES BB  soes n§is

=] 4 [ Main

by Input1 TRUE BOOL a
= Input2 TRUE  BOOL O
= Output TRUE  BOOL ]
—] {2} Global variables

5 RETAIN variables

&

o A e P

- 4

13

=
=

~

v

]
o PR NG A
| % & (*Boolean AND*)
. 1% (“Muitiphy*)
= + (“Addition”)
. %5 - ('Subtraction’)
£ 1 (*Divide”)
= £ 1 (“copy (1 gain)*)
Ers < (Less than")
—] (*Less or equal’)
=] <> ’Is notequal’y
§u = (s equal’)

> (‘Greater than*)
(*Greater or equal”)
£ >»[1,0,K] (*Put array item (3 dim)*)
5 >> 4] ("Put array item (2 dim)*)
2 2 [I1(*Put array item (1 dim)*)
[LJ,K] >> (*Get array item (3 dim)*)
[1J] >> (*Get array item (2 dim)*)

Define ENUM  Graphics

It is also possible to change a variable state by double clicking on it (in the program or in the dictionary)
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Create and configure an application

HE=IR & & @ E §o| & B RN
L) ]

4 [ Main
Input1 TRUE BOOL a
Input2 TRUE BOOL [m]
Qutput TRUE  BOOL ]

1 Global variables

O
o
o
» RETAIN variables

»
Input2
kL =
| o
H
3 FALSE (0]
o O Lock
’ £ & ("Boolean AND")
3 Uniock 2 * (*Multiply)
- 2 +(Addition’)
N 2 - (Subtraction”)
£ | (Divide")
% L& 1 (copy (1 gain)*)
o3 £ <("Lessthan’)
—] % <= (‘Less or equal’)
Bl < (15 notequar)
5 = =(Is equal’)

L3 >=(*Greater or equal®)
£ >> L4 K] (‘Putarray item (3 dim)")
3 >>[I,J] (*Putarray item (2 dim)*)

= >>[I] (*Putarray item (1 dim)"}
[LJK] >> (“Get array item (3 dim)')
[1J]>> (*Get array item (2 dim)*)

7 >(*Greater than")

st Define ENUM Graphics

4.4. Downloading an application on a runtime

The project is now working correctly so it can be downloaded to a Runtime. First, exit the simulation mode
clicking on the « simulation » button.

| o] e~ |3 & TR E §of @B~ R

[ Type | Dim. | Attrib. | Syb. [ Init val.
| 4 D Main
o Input TRUE BOOL a
=] Input2 TRUE BOOL a
(=Y Output TRUE BOOL a

£ Global variables
RETAIN variables

@]
i

s B
= .
*
I
¥ < >
|
6 A
" 3 & (‘Boolean AND')
Ly * (*Multiply*)
e +(*Addition”)
n - (*Subtraction”)
(*Divide*)
% 1 (*copy (1 gain)*)
0l <(Less than*)
| <~ (Less or equar)
Lz <> ("Is not equar’)
§u
>(*Greater than")
>=[*Greater or equal*)

>>[1JK] (*Put array item (3 dim}*)

>> 1] (*Put array item (1 dim}
[1J.K1>> (“Get array item (3
>> (*Get array

To set the communication parameters, double click on the bar at the bottom of the window.
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Create and configure an application

Fle Edt View Insen Project Took Window Help

BBEG XCEXS|o|leAe|EaNAQESH S8~

4 B _Tutorial

am 7
v [ Exception programs 4 () Main
4 @ Programs o Input1 BOOL o
) Main o Input2 BOOL a
4 & Wakch (for debugging) o Output BOOL [m]
® SoftScope {ar Global variables
Bl initial vasues 5 5 RETAN varisbles
) Bining Configuration
A Profiles
§q Gloval defines =
£ variavies L &
b K Tipes - Input1 — = Output
W (4 Projects) P
= Input2 |
=
*
|
O
4
7
Dwvide’)
% (*copy (1 gain)*)
. ess than")
‘Less or equal’)
B © ('ls not equar’)
15

Loading application symbols. ~
No error cetected

Loading application symbols.
Main

pStartup
pShutDown
pOnDNZero
pOnBadindex

B o

1 A 0.1 | ssex18 | 00 5% 1

Here it is possible to edit the communication settings. Fill the address and port of the runtime clicking on
the [...] button.

Communication Settings X
TS5 Runtime v
Cancel
192.168.33.120:502 |
Browse
Help

Set the communication settings. Then press OK.
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Create and configure an application

Communication Settings X
(@ Ethernet TCP/IP
IP adress: ‘192-1 68.33120 | Cancel
Port number: 502 Help
(O Serial link
PC port:
Baudrate: 19200
Parity: MNone
Stop hits: 1

Note: the default communication port on a Windows runtime is '502". On specific runtimes (Linux,
VxWorks, QNX...) it is “1100".

Connect the Editor to the Runtime clicking on the « online » button.

Gl ol d DR QE S 6 a(®

BBE(SXCKFXS

Workspace: Main
4 B _Tutorial =1 ame Type escn,
v ([ Exception programs = 4 [) Mai
4 i Programs Input1 BOOL m)
) Main o Input2 BOOL a
4 @ Watch (for debugging) o Output BOOL (m]
@ Soft Scope { Global vaniables
il itialvalues i 5 RETAR variables
1 Binding Configuration *
R Profiles
§g Global detines 5]
{3 vaniadies g &
v E Tiwes w Inputt 1 ] Output
B (N Projects) P o
g Input2 L
*
*
1
)
4
7
S
e
a (*Less or equal’)
2 (s not equar’)

Loading application symbols.
No ermor detected

Loaaing application symbols
Main
pStartup

Resdy | Fat | Detaut | Oftune 1921683312050 PIERTS | sx18 | 00 5%

If no application is running on the Runtime, straton asks “do you want to download the application now?”
click on "Yes".

Otherwise, the toolbar will show that you are connected to the runtime but it has no application.
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Create and configure an application

BEE S s rFrXsS|[o|l«+: |@&&MASE §a| 65 = I Noapplcation

8

To start or stop an application which is loaded on the runtime, use the traffic light icon on the toolbar:

BEE S i rX=S| o]~ &R A GE S| 8 = Noappication @Em@i

The application is now running on the Runtime. Variables values can now be modified as in simulation
mode.

Fle Edt Niew Insert Project Tooks Window Help

BBB|SIiCTEXS 4| | & WA DE Gl 75 Maum seee BRERE M6 D
Workspate i}
=
4 [ Main
o Ingutd TRUE  BOOL [m}
) Main o Input2 BOOL o
{8 Walch lfor debugging) =% Output BOOL [m]
) Soft Scope {r Global variables
EH initial vatues ' B RETAIN variables
i Binang Connguration v
8, Profiles
§4q Gloval defines =
£ variables = &
v E s - " Output = FALSE
W (W Projects)
» Input2 = FALSE [
=
*
I
<K < >
@ P -
d & ["Boolean AND")
i Multply)
-
£
B llu;"]
|5 |
("Greater or equal’)
LK) {*Put arvay ltem (3 dim}"}
091 (Put array item (2 dim)’)
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Create and configure an application

4.5. Fieldbus configurator

To configure the fieldbus parameters, start by opening the Fieldbus Configurations:

Fde EGt View Insent Project Tooks Window Help

BBRIG I AXS|ales|alE@IRAQGESG SE

4 B _Tuorial =]
> [ Exception programs |
4 @ Programs o Inputt BOOL m}
) Man o
4 @ wateh for debugging) e
& Soft Scope £ Global vanables
Bl il vatues o RETAIN variables
1l Binding Configuration
A Profiies
§g Global defines.
Gy variadies
b & Types
W (4 Projects)

Input1 1 . Output
Input2 |

L0 LS=WT s F G

> [LJXK] (*Put array item (3 dim)")
> (LJ] (*Put array item (2 dim)")

> 1] (*Put array item (1 dim)*)
1K >> (*Get array item (3 dim)")
1J]>> (“Get array item (2 dim)*)

Building application data.

<107 BOOUSINT, § INT, 26 DINT/REAL; 14 LINTLREAL: 0 TIME; 1 STRING: 0 WSTRING - CRC = 84bec801>
<13POUs - 3 programs, 8 sub-programs, 2 UDFBs >

Relocatng code,

<Code CRC=53412892 - File CRC=981cta1a - Retain CRC=4edf1459 - Size=2040 >
No error detected
Online Change is isabled

Hame. Value Y| Type Dim_| Atinb.___| Syb. | Init ...
£ "---..‘ i, Global variables
-g Bl RETAIN variables
b 0 Main
- & pOnBadindex
] s pOnDinZers
T [ pShutDown
D) pStartup
<
B
&l
EN
« >
[
¥ [ Hame Value Dim.
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Create and configure an application

From this window, choose the fieldbus to be used:

\, Add Cenfiguration
Select a configuration

(Al

Anybus

CAN

DMP3
EthernetP (QDWA)
IEC 60870

IEC 61850
MoDBUS

OPC UA
Profinet 10
Shared Memaory

-

v v v v v v v v v v

0K

Cancel

More help and detailed information about the fieldbus configuration is available in:

Help > Tutorials > Protocols.
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Frequently Asked Questions

5. Frequently Asked Questions

HOW TO MODIFY STRATON EDITOR OPTIONS?

Editor options can be changed clicking on Tools > Options

\, Opticns X

3 Window Mame | Value | Value range |

A Character fonts More recent projects 9 (0-9)

Editing Maximum of open documents 16 (1-258)

# Colors Show menu

[ Diagrams Show tools bar

b Prefixes Show status bar

Tooltips Show start page

Extensions View layout (Default)
Impart Defines the maximum shown recent projects in the menu.
Export
Default Cancel
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Frequently Asked Questions

HOW TO MODIFY THE PROJECT'S SETTINGS?

The project settings can be accessed doing a right click on the project and then clicking on Settings. The
main settings can be found in the ‘Options’ tab.

Project settings

[ s\ Tutorial

Target
Compiling
Test
Advanced
(am

Default

Setting modes

"o

¥ Cycletime
@5 compiling

[il. Store complex variables in a separate seg...

= Online change

[y version

3 Libraries

3 Extern objects

Ldl Code Checker rules
& Version control

Communication parameters for Online connection to the target.

Double dick to edit.

0

Debug

Mo

INACTIVE
V2-2023/102/123 11:33
Edit...

Edit...

Edit...

Mo

[oc ]

WHERE TO FIND SOME ADDITIONAL HELP?

They are two ways to find advanced help:
P Access to the tutorials in: Help > Tutorials

» At any moment, select a specific element and press F1 to obtain more help

Fie Edt View Insen Project Took Window |Help

BBRI& A EXE 6|« o mpc.

4 B _Tworial
v Exception programs
4 @ Programs
) Main
« @ watch ror dedugging)
& Soft Scope
B Inital vatues
0 Binding Configuration
R Pronies
§g Global defines
&) vaniables
b [ Types
W (4 Projects)

B = § w0t

e

Q search.

2 sbout.

Language...

A Efl@e ™

Distibuted Application pdf

EBD tricks and tips paf

Free Form_Ladder.pdf

Getting Started with Linux runtime pof

Getting Started with RaspberryPi Runtime.pdf

Getting Started with STRATON.pdf
Opline change. pdf

Output Window.pdf

Project automation.pdf

Shered memory.pdf

Signal ressources.pdf

WiibuKey runtime update pdf
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Frequently Asked Questions

IS THE MAIN PROGRAM HAVING A SPECIAL ROLE?

In straton, the Main program does not act differently than the other ones. It is possible to change the
programs execution order and cycle by right clicking on the project > Cycle.

M cycle X
Lt =+ @

Statistics: (unit = programir
- Maximum: 3 at cycle 0\

- Minimum: 3 at cycle 0\r
-Average: 3\r

Calculated on 1000 cvcles

]
]

4 [ Programs (3)
@ Main
pStartup
pShutDown

4 [ sub-Programs (2)
pOnBadindex
pOnDivZero

I8 EEE |2
—
L]
EEN
RN
RN

HOW TO ACTIVATE/DEACTIVATE TRACK CHANGES?
If active, the track changes marks modifications in the main window with the defined color.

The track changes can be activate/deactivate using Tools -> Options -> Editing -> Track changes.

N E=A

T

Input1 ~—1 | Output
Input2 —1

T ¢ E

&
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